ArcGIS中使用的Python版本

本文目录
  • 正文

在ArcGIS中经常会使用到Python,从ArcGIS 10开始,Python在ArcGIS中的应用更加广泛,并且会自动安装。那么ArcGIS不同版本所使用的Python版本有什么不同呢?

ArcGIS系列软件所使用的Python版本对应如下

ArcGIS for Desktop

  • 10.3 - Python 2.7.8 and Numerical Python 1.7.1
  • 10.2.x - Python 2.7.5 and Numerical Python 1.7.1
  • 10.2 - Python 2.7.3 and Numerical Python 1.6.1
  • 10.1 - Python 2.7.2 and Numerical Python 1.6.1
  • 10 - Python 2.6.5 and Numerical Python 1.3.0

ArcGIS for Server

  • 10.3 - Python 2.7.8, Numerical Python 1.7.1, and Matplotlib 1.3.0
  • 10.2.x - Python 2.7 (64 bit)
  • 10.1 - Python 2.7 (64 bit)
  • 10 - Python 2.6.5 and Numerical Python 1.3.0

注意

并不建议单独安装一个python版本,可能会在ArcGIS的使用中带来兼容和根目录的系列问题。

如您有疑问,可在文末留言,或到QQ群提问。

本站QQ群(一):291616564(满) 麻辣GIS

本站QQ群(二):166408035(新) 麻辣GIS(二)

微信公众号:malagis,扫描右边二维码直接关注。

微信捐助麻辣GIS 支付宝捐助麻辣GIS

如果本文对您有所帮助,欢迎对我们团队进行打赏捐助,让我们在传播3S的路上可以走得更远。


作者:,GIS爱好者。
分享本文,请您带上本文链接

已有 8 条评论

  1. teber
    1#
    teber  · 2017-10-19 20:13

    你好,问问大神你这有10.2或10.4的engine吗?如何安装

      1. Sailor
        Sailor  · 2017-10-20 08:53

        目前我手头的包还不完整哈,得再整理整理。

  2. LHEHE
    2#
    LHEHE  · 2018-01-08 22:05

    您好,请问ArcGIS自带的python可以移到其他目录吗?可以的话怎么操作呢?

      1. Sailor
        Sailor  · 2018-01-09 09:43

        为什么要移?

          1. LHEHE
            LHEHE  · 2018-01-09 10:05

            http://blog.sina.com.cn/s/blog_6fc4f6f301012bdp.html
            文章中说要放在默认目录,否则arcpy不能安装,我安装的时候更改了目录,现在想改回去。

              1. Sailor
                Sailor  · 2018-01-09 10:11

                这个没尝试过,不行的话可以重新安装ArcGIS尝试一下。

                  1. LHEHE
                    LHEHE  · 2018-01-09 10:16

                    好的,谢谢。

  3. LHEHE
    3#
    LHEHE  · 2018-01-09 10:15

    好的,谢谢。

发表评论